FireFox bug with version 2.4

Topics: Developer Forum
May 18, 2013 at 11:22 PM
Good morning

I recently downloaded 2.4 (2007.12.21) of the JavaScript SOAP client and I found that the newer versions of FireFox receive cut off data from the web services.

I fixed the problem by replacing some code within the "SOAPClient._node2object" method so that it uses the "arr" array to populate the "obj" object - same as version 1.4 (2005.12.10) of the script.

Yours sincerely

Werner